The Firing Line Forums

Go Back   The Firing Line Forums > The North Corral > Competition Shooting

Reply
 
Thread Tools Search this Thread
Old August 20, 2017, 09:26 PM   #1
AzShooter
Senior Member
 
Join Date: June 20, 2006
Location: Surprise, Az.
Posts: 425
My faster Steel Challenge Ever.

Drove to the range today for our monthly Steel Challenge match. It's only a 30 minute drive and very relaxing.

Got all set up with my backup Mark III Hunter model. I love how this has been shooting for me. First stage, 5 to go, went well. My shooting buddy commented on how nice the Hunter looked.

Second stage, not so well. Ran the first string and my gun went full auto. This was with the stock trigger. So I ordered a replacement trigger kit. Should solve the problem. Once the gun goes full auto it's considered unsafe and must be refused from the match. Better luck next month.

Hopefully I'll get my Mark IV shooting better. It's jamming and I think it's do for a real good cleaning with Kroll and a good brush. First round won't go in all the way and won't release from the chamber. I also put a new extractor on the gun.

Here is the Mark III.

AzShooter is offline  
Old August 21, 2017, 11:31 PM   #2
JohnKSa
Staff
 
Join Date: February 12, 2001
Location: DFW Area
Posts: 21,027
Quote:
Ran the first string and my gun went full auto.
That's got to be exciting.

That doesn't seem to be a common failure mode for these pistols. When you get in there to replace the trigger, it would be interesting to know what went wrong.
__________________
Did you know that there is a TEXAS State Rifle Association?
JohnKSa is offline  
Old August 23, 2017, 10:47 PM   #3
rdtompki
Senior Member
 
Join Date: March 15, 2014
Location: San Franciso Bay area
Posts: 104
Probably a DQ, but what was your time on that first string? Or did you run the gun empty before you could get 5 hits
__________________
NRA Life Member
CRPA Life Member
rdtompki is offline  
Old August 23, 2017, 11:04 PM   #4
AzShooter
Senior Member
 
Join Date: June 20, 2006
Location: Surprise, Az.
Posts: 425
They didn't record my time.
AzShooter is offline  
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2017 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06903 seconds with 8 queries