The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools Search this Thread
Old July 27, 2018, 09:41 AM   #1
fjnida
Junior Member
 
Join Date: November 8, 2014
Posts: 7
Browning A-5 not cycling

I have an old A-5 that has problems with cycling. Everything seems to function correctly. It is a light 12 made in 1956. How do yo know if the friction rings are good . Should I try replacing these first ?
fjnida is offline  
Old July 27, 2018, 09:54 AM   #2
natman
Senior Member
 
Join Date: June 24, 2008
Posts: 2,211
Download this.

Page 12 has the setup pictures. The outside of the mag tube should be *lightly* oiled; i.e., put a small drop of oil on a patch and wipe the tube. Plain gun oil, no teflon or moly wonder oils here.
__________________
Carpe diem maƱana
natman is offline  
Old July 27, 2018, 11:05 AM   #3
tangolima
Senior Member
 
Join Date: September 28, 2013
Posts: 2,042
Quote:
Originally Posted by fjnida View Post
I have an old A-5 that has problems with cycling. Everything seems to function correctly. It is a light 12 made in 1956. How do yo know if the friction rings are good . Should I try replacing these first ?
Need more details. Exactly what sort of cycling problem does it have? Failed to extract / eject, or failed to feed. What shells were you shooting? When and what led to the event? How many friction rings does the shotgun have?

-TL

Sent from my SM-G930T using Tapatalk
tangolima is offline  
Old July 28, 2018, 08:29 PM   #4
Drm50
Senior Member
 
Join Date: November 10, 2014
Posts: 530
Check out the buffer spring, These very seldom get cleaned and from lube and
cleaners all the crud will end up there. Will slow return down till it fails. This is
often overlooked and blamed on friction rings.
Drm50 is offline  
Old August 3, 2018, 10:44 PM   #5
jrothWA
Senior Member
 
Join Date: November 11, 2006
Posts: 2,292
Detail [clean it] and then

take a well-worn kitchen scotch-brite pad and polish lightly the mag tub OD,
then place a drop of Mobil 1 synthetic oil on the tube were the friction ring sit,''and reassemble.
function fire to see if cycling occurs, if not then order a repalcement set of both the friction bronze ring and the steel ring. Get a new mag tube spring and the long small diameter spring that runs down the stock.
cycle a gain should have good operation.

good luck.
jrothWA is offline  
Old August 4, 2018, 08:40 PM   #6
fjnida
Junior Member
 
Join Date: November 8, 2014
Posts: 7
A-5 Not cycling

Thanks for the info guys. I have been using factory Winchester duck & pheasant.
fjnida is offline  
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2018 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06786 seconds with 10 queries