View Single Post
Old December 2, 2012, 08:29 PM   #1
Senior Member
Join Date: August 13, 2010
Posts: 407
Problem with RCBS 505 Scale

So I've been using a RCBS 505 scale for the last few years. I went down to reload tonight and am having a problem with it. I had this problem in the past once before and I tried it out again the next day and it worked fine.

The problem I'm having is when I try to zero the scale it seems like it's way off. So I adjust the height of the scale to zero it and once I get it zeroed I take the pan off and put it back on, and the scale has a different reading. I can then take the pan off and put it back several times and the scale has the same reading, but the marks will no longer be zeroed the mark on the beam will usually be higher reading like something is in the scale. I will then zero it again to these marks. Then once I remove the pan and put it back on, the beam will be quite a bit lower. It's just a back and forth cycle and I can never get it zeroed so that it will read the same thing after removing the pan and reinstalling it.

Anyone had this issue? Any tips to get it fixed? Having had this issue, it always makes me scared it's going to act up while in the middle of loading and throw my loads off, but so far I've been pretty lucky with that.
Fusion is offline  
Page generated in 0.03894 seconds with 7 queries