PDA

View Full Version : Failure to eject / stuck bolt


0351A
February 19, 2013, 02:25 PM
Hey, picked up a new fulton armory 308 AR yesterday and am wondering if anyone is familiar with the following problems. First, when manually ejecting a round by racking the charging handle, it seems to stick, which requires me to brace the butt stock and use both hands to get it back. I am not weak and have used ar15s for years. Secondly, sometimes it doesn't grip the round, leading to double feeds. I haven't yet fired it, and it is brand new, so perhaps I should try to put a few rounds through it first, but I have never experienced this before. Is anyone familiar with this sort of problem? I tried several different kinds of ammo, both in 308 and 7.62x51.

Unclenick
February 20, 2013, 09:14 AM
Not familiar, but my assumption is that unless the carrier is binding somewhere (rub marks would show) that the gas system will also have trouble pushing the bolt back. I would call FA to inquire about it. See what they say.

oneoldsap
February 20, 2013, 03:25 PM
Your first step should be a good thorough cleaning . New guns are always full of crap !

DnPRK
February 21, 2013, 07:16 AM
Put a dab of grease on the back of each bolt lug. After you shoot a few magazines, it should loosen up.

0351A
February 23, 2013, 06:08 AM
Thanks for the advice. I figured it would just be that it's new, but something about spending that much makes me paranoid. I went ahead and went to the range twice and dumped a couple hundred rounds. It seems just fine now.

4V50 Gary
February 24, 2013, 02:39 PM
Break in period. Sounds like things are normal now.

Unclenick
February 24, 2013, 02:48 PM
Good to know they can be that stiff new. If the gas system didn't balk at it, then it's good to go.