View Full Version : A little trouble with an AR. Bolt won't lock

June 7, 2011, 05:23 AM
I bought a used Lone Star carbine with collapsible stock as a spare back up for my primary carbine. (I'm headed to Thunder Ranch and they recommend a spare).

I replaced the cheapie collapsible stock with an A-1 stock, and used the buffer tube, recoil spring and buffer from an A-2 to do it.

The rifle functions fine except for not locking open on an empty magazine. This fails to occur after the last round is fired, and when manually opening the action.

Switching the A-2 spring and buffer for the carbine spring and buffer didn't work either. I tried the carbine buffer with the rifle spring, and vice versa. No joy.

The buffer slides freely in the tube with the spring removed. The bolt lock operates fully with any magazine I try when I take the upper off the gun.

When I hold the bolt lock in with my thumb when firing the last round, the bolt locks open normally. When I retract the bolt manually, I have to press the release lever pretty hard to lock it open, but the bolt will slam forward if I rotate the rifle 90 degrees, as when inspecting the breech.

This has got to be a simple fix, but I'm not getting anywhere.

Recommendations? I may just take it with me like it is, as it's just the spare and not my primary, but would like to get it straight if I can.

The United States Marine Corps: Providing the enemies of America the opportunity to die for their countries since 1775. Semper fi.

June 7, 2011, 06:05 AM
I'm thinking you might need a new Bolt Catch Dentent Spring.
Number 9 on the diagram here. Possibly the rest of the Bolt Catch Parts as well. That's where I would start looking at least.


June 7, 2011, 08:59 AM
Is this post in 2 places?You used some combination of A-2 and A-1 parts.No problem,except the A-2 screw is long enough to go through the 5/8 in stock spacer.Suppose your A-1 stock did not have the A-1 screw and the A-2 screw was sticking out in the tube an extra 5/8 in.Might that be your issue?

June 7, 2011, 04:26 PM
You did not say if the rifle worked with the "El Cheapo" stock that came with the rifle. First things first. The rifle could have had gas issues before you changed anything, not unusual with generic AR's.

June 7, 2011, 05:05 PM
The A1 stock requires a short screw for the buttplate.

If you use the long A2 screw, the buffer does not travel to full depth in the buffer tube.

June 7, 2011, 06:09 PM
It was indeed the A2 stock bolt that was the issue. Thank you HiBC and DnPRK for your input. I had thought about the A2 bolt prior to your input, and your feedback reinforced my thinking. When I got home today I cut 5/8 inch off of the bolt with a Dremel tool and it worked perfectly.:D

Thunder Ranch, here I come!

Thanks all.