View Full Version : 700sps varmint trigger screws unajustable?

February 22, 2011, 01:09 AM
I tried to lighten the trigger pull on my 700sps varmint (brand new) by following some online instructions which called for cutting out the glue on the overtravel and sear adjustment screws which i did, but when i tried to break them loose with my allen wrench they stripped my tools and didn't budge an inch. How do I get these stubborn screws loose?

February 22, 2011, 03:21 PM
Acetone on the screws to remove the glue/threadlocker.
If that doesn't work, a tiny bit of heat will do it.

Did you actually strip the threads, or is there glue in the hex head hole blocking your wrench from getting a purchase?

February 22, 2011, 09:56 PM
I stripped my hex wrench (grr), the screws are just fine. Ill try a dab of acetone and if that doesnt work just a tiny bit of heat. I cleaned all the glue out of the hex holes in the screws with a pin and tried to clean it out of the threads as much as possible. Im guessing theres still some glue down in the threads so hopefully acetone will break it loose.

February 22, 2011, 09:59 PM
Thanks for the tip, I see you prefer to shoot a diffrent type of dog than I lol. Happy shooting.