View Full Version : Scope adjustment knob frozen ????

August 2, 2000, 07:31 AM
Tried this in the rifle forum and no one has seen this problem. Maybe someone here can help.
Went to the range yesterday to help a buddy sight in his rifle. He has a variable power Leupold. It has been sitting for a while and it was last used on about 2X. We couldn't get it to move up at all. I didn't want to put a wrench or anything on it and I'm a little nervous about soaking it with oil. Has this happened to anyone here? Short of sending it back to Leupold what can I try?

"Some people spend an entire liftime wondering if they made a difference. Marines don't have that problem."
Semper Fi

George Stringer
August 2, 2000, 08:03 AM
DannyO, the best thing to do is to send it to the manufacturer. George

August 11, 2000, 11:55 PM

There is a heavy grease under the adjusting ring to help seal the scope against moisture and that grease has hardened.

I Ran up agains the same thing in a *very* old Leupold scope I got at a gun show.

As this scope was pretty shabby looking anyway, I put a drop of "Break Free" on the joint and kept wiggling the part ( gently) untill it loosened up.

George is right tho- Leupold ( a local company ) is very good about repairing their products and the price is right- Free in most cases


Lay up some blackpowder and flints
The rest we can build, if need be