The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Thread Tools
Old May 28, 2001, 01:26 PM   #1
Junior Member
Join Date: May 28, 2001
Posts: 5
I have a Marlin 60sb with a dove tail rail scope mount on it. the only problem is that I can't keep any scopes in place. they stay for a while, but after prolonged firing either the scope and/or rings move dramatically out of place, altering point of impact. Does anyone know how to solve this problem?
jjtodd is offline  
Old May 28, 2001, 01:55 PM   #2
Art Eatman
Staff Lead
Join Date: November 13, 1998
Location: Terlingua, TX; Thomasville, GA
Posts: 23,061
1. Does the mount "just move", or do the screws loosen up? If the latter, try Loctite.

2. Have it drilled and tapped for "real" scope mounts, a la Weaver...

Best luck,

You're from BATFE? Come right in! I use all your fine products!
Art Eatman is offline  
Old May 29, 2001, 02:39 PM   #3
Junior Member
Join Date: May 28, 2001
Posts: 5
the screws never loosen up and i've tryed loctite but the darn thing goes right on moving. thanks for your help. I'll think about drilling and tapping.
jjtodd is offline  
Old May 29, 2001, 03:42 PM   #4
kurt IA.
Senior Member
Join Date: February 19, 2001
Location: Iowa
Posts: 141
You mite try another set of rings first, if that don,t work then drill an tape, as Art said.
kurt IA. is offline  

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 10:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2015 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent:
Contact Us
Page generated in 0.05730 seconds with 7 queries