The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old October 6, 2013, 06:26 PM   #1
beaver
Senior Member
 
Join Date: May 29, 2007
Posts: 115
Weatherby Model 82

have a weatherby model 82 12 gauge wont eject fired shells any ideas whats wrong. I am just asking for suggestions about what to check first i have allready cleaned it real well and lubed it. thanks for any ideas
beaver is offline  
Old October 6, 2013, 07:40 PM   #2
PetahW
Senior Member
 
Join Date: September 19, 2008
Posts: 4,679
.

The first thing I would check is that the ejector moves freely in/out, in it's hole in the bolt face, and that it's coil spring hasn't collapsed or gone walkabout / broken.


.
PetahW is offline  
Old October 6, 2013, 09:08 PM   #3
beaver
Senior Member
 
Join Date: May 29, 2007
Posts: 115
Will check this thank you
beaver is offline  
Old October 7, 2013, 05:15 AM   #4
Virginian-in-LA
Senior Member
 
Join Date: February 11, 2012
Location: Evangeline, LA
Posts: 725
Also check and make sure the bolt is coming all the way back when firing. Easiest way is to put a piece of masking tape on the receiver so the handle tears it.
__________________
What could have happened... did.

I do not trust Remington's dating service accuracy. If they were Match.com, you could end up with Nancy Pelosi.
Virginian-in-LA is offline  
Old October 7, 2013, 10:08 AM   #5
PetahW
Senior Member
 
Join Date: September 19, 2008
Posts: 4,679
.

+1 - If the bolt's not being pulsed back far enough to eject the fired shell, it might be that the gas port(s) in the bottom of the bbl (inside the ring around the mag tube) are partially plugged.

The port(s) are usually able to be cleaned out with a bent wire of the proper diameter.



.
PetahW is offline  
Old October 7, 2013, 10:26 AM   #6
BigD_in_FL
Junior member
 
Join Date: December 20, 2012
Location: The "Gunshine State"
Posts: 1,981
Might want to check out some of the offered solutions to a similar problem here:

http://www.shotgunworld.com/bbs/view...f=114&t=190505

and see if those might work for your problem
BigD_in_FL is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06976 seconds with 9 queries