The Firing Line Forums

Go Back   The Firing Line Forums > Hogan's Alley > Handguns: The Semi-automatic Forum

Thread Tools
Old April 20, 2013, 07:39 PM   #1
Junior Member
Join Date: January 27, 2011
Location: South Carolina
Posts: 12
Trouble Cleaning Barrel/slide Ports!

I have a Springfield Armory Ultra Compact V10 1911 that's ported. The oval ports in the slide are accumulating a grayish layer of residue, and I'm having trouble cleaning them out. I only shoot jacketed bullets, so I know it's not lead. Any ideas?
I tried pipe cleaners, Q-tips, fishing line, etc. and nothing budges it.
jerryboy is offline  
Old April 20, 2013, 10:39 PM   #2
Senior Member
Join Date: April 12, 2010
Location: Lake Martin, AL
Posts: 2,228
Sounds like the perfect job for an ultrasonic cleaner.
lamarw is offline  
Old April 22, 2013, 04:02 PM   #3
Senior Member
Join Date: May 15, 2012
Location: Texas
Posts: 1,054
If it's like ports in a shotgun BBl good luck. I won't do that again.
pete2 is offline  

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 01:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2015 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent:
Contact Us
Page generated in 0.05020 seconds with 9 queries