The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Art of the Rifle: Bolt, Lever, and Pump Action

Reply
 
Thread Tools
Old September 26, 2012, 10:28 AM   #1
old fart
Senior Member
 
Join Date: May 24, 2009
Posts: 296
rings won't tighten to base?

i have a savage mark 2, it uses the two piece weaver bases. i bought a set of quad lock rings for it, but with the rings tight i can move them front to back on the bases. what can be the problem?, thanks for any help.
old fart is offline  
Old September 26, 2012, 04:11 PM   #2
old fart
Senior Member
 
Join Date: May 24, 2009
Posts: 296
found my problem, the bases on the gun was #24 weaver. the savage takes #16 weaver, now i don't know what kind of rings fit the #24 but when i went and got #16 bases my ring tighten down good. they look just alike but there is a difference. thanks
old fart is offline  
Old September 26, 2012, 06:26 PM   #3
Creeper
Senior Member
 
Join Date: September 9, 2008
Location: Woooooshington
Posts: 1,797
That's weird, but without actually seeing it, I guess anything is possible. Glad to hear you've sorted it.

Cheers,
C
__________________
Shoulder Drive Nicholson Club
Creeper is offline  
Old September 26, 2012, 06:29 PM   #4
wild willy
Senior Member
 
Join Date: March 8, 2006
Posts: 204
Maybe you got bad bases or something. A #24 Weaver base works fine on Savage Rimfire rifles in fact as far as diameter of the receiver and the diameter of the base a #24 is one of the closest fitting bases.The difference in the two is the height #16=.205 #24=.271
wild willy is offline  
Old September 26, 2012, 07:00 PM   #5
Mobuck
Senior Member
 
Join Date: February 2, 2010
Posts: 2,287
Unless the rings were defective, there's no difference in the area that mates with the rings. The different numbers indicate what actions they fit.
Mobuck is offline  
Old September 28, 2012, 09:11 AM   #6
Fusion
Senior Member
 
Join Date: August 13, 2010
Posts: 388
Did they come on the rifle? I've heard of Savage shipping the rifles with undersized bases and rings, although I've never personally seen it.
Fusion is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06215 seconds with 7 queries