The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Art of the Rifle: Semi-automatics

Reply
 
Thread Tools
Old September 25, 2012, 04:40 PM   #1
Dearhunter61
Senior Member
 
Join Date: May 5, 2008
Location: Texas
Posts: 473
EOTech 553

Has anyone else Had trouble with it staying sighted in? Or on target? I put it on my new sig and went and shot it Sunday but when we changed shooters this simple movement changed the aim point.

Thanks for any and all help.
Dearhunter61 is offline  
Old September 26, 2012, 07:09 AM   #2
Crow Hunter
Senior Member
 
Join Date: January 27, 2012
Posts: 1,078
How far did it move?

How far away from the target were you?

Are you sure the mounting bolts are tight and haven't backed out any?
__________________
I am no longer participating in gun forums.

Good luck.
Crow Hunter is offline  
Old September 26, 2012, 08:52 AM   #3
Destructo6
Senior Member
 
Join Date: March 18, 1999
Location: Nogales, AZ USA
Posts: 3,778
Make sure the rail is tight and the EOTech is mounted securely.

The way it should work is that if it is properly sighted in, it should be on for anyone.

If someone doesn't know how to use the EOTech (eg aligning the dot with the front sight), then you could have problems.
__________________
God gave you a soul.
Your parents, a body.
Your country, a rifle.

Keep all of them clean.
Destructo6 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07403 seconds with 9 queries