The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old March 29, 2012, 04:40 PM   #1
SRE
Senior Member
 
Join Date: May 15, 2011
Location: Southern York County, PA
Posts: 101
Winchester Model 190 .22 help

Ok so I rebuilt an old Win 190. This thing has had failures to eject properly since day one. Stovepipes all the time. I've replaced the recoil spring and firing pin, extractor looks fine! (Firing pin acts as the ejector)

I've polished everything on this rifle. Bolt and receiver, also trigger assembly. Action is smooth as glass. For the life of me I can not figure out why it stovepipes. Seems as if the recoil spring is too heavy? Maybe lighten in up a bit?

Anyone else had any issues with the Winchester 190? This model was the first model rifle I was given when I was a boy so they hold sentimental value.
__________________
Combat Commander
SRE is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06642 seconds with 9 queries