The Firing Line Forums

Go Back   The Firing Line Forums > The North Corral > Lock and Load: Live Fire Exercises

Reply
 
Thread Tools
Old April 2, 2000, 06:56 AM   #1
twoinchgroup52
Senior Member
 
Join Date: August 28, 1999
Posts: 125
Took my new T/C Contender with 223 Rem barrel to the range today. Accuracy was excellent but had about 35% failures to fire. Examination of case primers showed that the failures were due to light firing pin hits. Anybody else experience this problem??
twoinchgroup52 is offline  
Old April 2, 2000, 06:37 PM   #2
JBP
Senior Member
 
Join Date: October 13, 1998
Location: Maryland
Posts: 471
What ammo where you using?

I have had problems with my 223 using PMC ammo with anywhere between 1 & 2 rounds per box not firing but the hits on the primer look the same as the ones that fired. No other ammo has given me that trouble. My NEF Handi Rifle handled the ammo without any problem.
JBP is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05691 seconds with 7 queries