The Firing Line Forums

Go Back   The Firing Line Forums > Forum Support > Site Questions and Tech Support (NO FIREARMS QUESTIONS)

Reply
 
Thread Tools
Old May 26, 2011, 10:59 PM   #1
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
I need to log in every time I open my browser

This started about a week ago as I never had to before. I don't know of any changes I have made to my system in the same time frame.

Has anything changed in this forum that might cause this? I don't have this problem on THR.

Thanks and keep up the good work!
Miata Mike is offline  
Old May 26, 2011, 11:08 PM   #2
JohnKSa
Staff
 
Join Date: February 12, 2001
Location: DFW Area
Posts: 18,286
Nothing's changed.

Are you checking the "Remember Me" box when you log in?

Are cookies enabled in your browser?

You could try clearing your browser cache (delete temporary files) and deleting all cookies.
__________________
Did you know that there is a TEXAS State Rifle Association?
JohnKSa is offline  
Old May 27, 2011, 09:41 AM   #3
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
Quote:
Are you checking the "Remember Me" box when you log in?
Yes.
Quote:
Are cookies enabled in your browser?
Yes. Sites like THR work, but now that I think of it the Ruger forum doesn't (not sure if it ever did though).
Quote:
You could try clearing your browser cache (delete temporary files)
I do that automatically every time the browser closes.
Quote:
and deleting all cookies.
I will delete the cookie to this site and see what happens. I will also recheck all of my browser settings to see if something changed on me. I am thinking it may some "security software" trying to make me and my computer safer.

Thanks for the reply!
Miata Mike is offline  
Old May 27, 2011, 10:00 AM   #4
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
I found that the cookie for this site expires at end of session (no matter if I check the remember me button or not). I did delete the old cookie and log on again.

I checked THR cookie that was almost next to your site cookie and found that theirs expires in March of 2012.

I will try a different browser and see if it makes a difference. It still would not surprise me if it was some funky firewall issue on my end.
Miata Mike is offline  
Old May 27, 2011, 10:43 AM   #5
tyme
Staff
 
Join Date: October 13, 2001
Posts: 3,156
I think you're confusing different cookies.

bbsessionhash expires at end of session. Even if you have a bbsessionhash cookie, sessions are invalidated after 20 minutes of inactivity.

bbuserid and bbpassword cookies keep your login info. Those are what allow auto-login and get you a new session if your old one has expired. They should be valid for 1 year.
__________________
“The egg hatched...” “...the egg hatched... and a hundred baby spiders came out...” (blade runner)
“Who are you?” “A friend. I'm here to prevent you from making a mistake.” “You have no idea what I'm doing here, friend.” “In specific terms, no, but I swore an oath to protect the world...” (continuum)
“It's a goal you won't understand until later. Your job is to make sure he doesn't achieve the goal.” (bsg)
tyme is offline  
Old May 27, 2011, 11:51 PM   #6
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
Quote:
bbuserid and bbpassword cookies keep your login info. Those are what allow auto-login and get you a new session if your old one has expired. They should be valid for 1 year.
Both bbuserid and bbpassword cookies expire at end of session, hence my confusion.
Miata Mike is offline  
Old May 28, 2011, 03:31 AM   #7
tyme
Staff
 
Join Date: October 13, 2001
Posts: 3,156
Have you tried with a different browser and a different computer?

Could not replicate in FF4.0.1 linux, FF4.0.1 Windows7, Chrome (win7), or Chromium (linux).
__________________
“The egg hatched...” “...the egg hatched... and a hundred baby spiders came out...” (blade runner)
“Who are you?” “A friend. I'm here to prevent you from making a mistake.” “You have no idea what I'm doing here, friend.” “In specific terms, no, but I swore an oath to protect the world...” (continuum)
“It's a goal you won't understand until later. Your job is to make sure he doesn't achieve the goal.” (bsg)
tyme is offline  
Old May 28, 2011, 10:44 AM   #8
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
I am using Firefox 4.0.1 as my primary browser, and am testing Internet Explorer 6.0.2900 with SP2 as we speak. Neither has worked today. I have not tried another computer yet.

Not a big deal, and I still suspect some software on my end trying to save me from something evil. I have had something odd before that turned out to be my Computer Associates security suite's firewall software. I tried after disabling that and it still made no difference.
Miata Mike is offline  
Old May 28, 2011, 11:03 AM   #9
tyme
Staff
 
Join Date: October 13, 2001
Posts: 3,156
Sorry, but it's on your end.

Did you force-configure your browsers to forget cookies at the end of your session? Firewall? Something?

(MSIE6? Seriously? http://www.theie6countdown.com/default.aspx )

Code:
POST /forums/login.php?do=login HTTP/1.1
Accept: <snip>, */*
Referer: http://thefiringline.com/forums/newreply.php?do=newreply&noquote=1&p=4599310
Accept-Language: en-us
Content-Type: application/x-www-form-urlencoded
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; ...)
Host: thefiringline.com
Content-Length: 204
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: __utma=X; __utmb=X; __utmz=X; bbsessionhash=X; bblastvisit=X; bblastactivity=0; __utmc=X

vb_login_username=Miata+Mike&cookieuser=1&vb_login_password=&s=&securitytoken=guest&do=login&vb_login_md5password=X&vb_login_md5password_utf=X


HTTP/1.1 200 OK
Set-Cookie: bblastactivity=0; expires=Sun, 27-May-2012 15:37:42 GMT; path=/; domain=.thefiringline.com
Set-Cookie: bbuserid=102508; expires=Sun, 27-May-2012 15:37:42 GMT; path=/; domain=.thefiringline.com; HttpOnly
Set-Cookie: bbpassword=X; expires=Sun, 27-May-2012 15:37:42 GMT; path=/; domain=.thefiringline.com; HttpOnly
Set-Cookie: bbsessionhash=X; path=/; domain=.thefiringline.com; HttpOnly
__________________
“The egg hatched...” “...the egg hatched... and a hundred baby spiders came out...” (blade runner)
“Who are you?” “A friend. I'm here to prevent you from making a mistake.” “You have no idea what I'm doing here, friend.” “In specific terms, no, but I swore an oath to protect the world...” (continuum)
“It's a goal you won't understand until later. Your job is to make sure he doesn't achieve the goal.” (bsg)
tyme is offline  
Old May 30, 2011, 06:58 AM   #10
Miata Mike
Senior Member
 
Join Date: May 22, 2010
Location: North East WI
Posts: 417
Turns out it was a Computer Associates security center software that was manipulating my cookies. All fixed and back to one year again. Thanks for having patience with me.
Miata Mike is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.09038 seconds with 7 queries