The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old August 19, 2010, 10:49 AM   #1
BDBroncosFan
Junior Member
 
Join Date: February 9, 2009
Posts: 9
Bolt dislodged from action - Century Arms Ultra 87 Shotgun

I was cleaning my shotgun last week and experienced a problem. While I was cleaning it, I noticed that the action became VERY stiff. I tried to work it loose, while doing this, the pump suddenly racked for me, and the action felt like it broke free from whatever the obstacle was. A couple minutes later, I thought it felt a little too loose. Upon further examination, it is apparent that the bolt has actually dislodged from the action itself. I can work the pump, but the bolt doesn't move at all, it has clearly been detached. From what I've determined, it appears to be virtually identical to the Remington 870 (i.e. swappable after-market parts, etc). I know you guys are knowledgeable here, and wanted to run it by a few of you gurus before I disassemble it and potentially screw it up more so than it already is. Any ideas on how to reattach it without disassembling? Or is that my only hope?

Thanks in advance guys!
BDBroncosFan is offline  
Reply

Tags
870 , century arms , pump , shotgun , ultra 87

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.04917 seconds with 7 queries