The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old July 4, 2010, 12:38 PM   #1
Xfire68
Senior Member
 
Join Date: March 31, 2010
Location: Communist State of IL.
Posts: 1,428
Intermittent Single action?

While shooting snap caps with my CZ 75B I noticed that the single action is intermittent? If I pull the hammer down with my thumb I can "sometimes" get the single action to engage. If I hold the hammer back and pull the trigger a bit more it might engage. Sometimes I can just pull the hammer back and it locks back like it should? Most of the time it goes right back up without catching?

What part engages to lock it into single action when I pull the hammer back?
Xfire68 is offline  
Old July 4, 2010, 05:43 PM   #2
Unclenick
Staff
 
Join Date: March 4, 2005
Location: Ohio
Posts: 10,308
The sear.

This is by far most likely to be a cleaning issue. Full disassembly and detail cleaning of all parts and holes will likely clear it up.
__________________
Gunsite Orange Hat Family Member
CMP Certified GSM Master Instructor
NRA Certified Rifle Instructor
NRA Benefactor Member
Unclenick is offline  
Old July 4, 2010, 11:20 PM   #3
Xfire68
Senior Member
 
Join Date: March 31, 2010
Location: Communist State of IL.
Posts: 1,428
Thanks for the info! That is a big help!
Xfire68 is offline  
Old July 6, 2010, 10:03 AM   #4
Unclenick
Staff
 
Join Date: March 4, 2005
Location: Ohio
Posts: 10,308
Let me add one thing. Be careful at reassembly to use a lube that doesn't get thick or sticky. Lots of guys have sprayed WD-40 into guns only to find, some time later, that it has gummed up and dust or fouling is held in place by it. It is good for loosening, water displacing (what the WD stands for), and short term rust prevention, but it is not a good wear preventing or high pressure lube so it should, in turn, be displaced by a proper gun oil after it is used on guns.

There are a lot of good lubes out there, and you want to use what you get sparingly so the cost isn't usually an issue if you spread it out as added cost per shot during the lifetime of the lube container. Nonetheless, good old inexpensive, homemade Ed's Red is an excellent overnight soaking solvent for fouling crud cleaning (followed by used toothbrush scrubbing the next day) and after wiping off, won't gum up gun internals. The transmission fluid in it withstands temperatures and pressure well. It is a good place to start, even if you decide to use Sprinco Machine Gun Lube or Wilson Ultra lube or some other high end product for a little extra slickness later.
__________________
Gunsite Orange Hat Family Member
CMP Certified GSM Master Instructor
NRA Certified Rifle Instructor
NRA Benefactor Member
Unclenick is offline  
Old July 6, 2010, 10:33 AM   #5
Xfire68
Senior Member
 
Join Date: March 31, 2010
Location: Communist State of IL.
Posts: 1,428
Thanks again Unclenick. I am pretty certain of the problem. It's not a dirty gun as I keep all my guns clean. It's I took my gun apart the other day and did a "Dry run" of a trigger job. I found step by step instructions on the CZ Gunsmith forum and before I "Did" the job I wanted to be certain I could take it apart and put it back together properly. In the process I am pretty sure I bent the Sear spring a bit. This is why I asked the question of what engages the single action so I could be sure that it was something I messed up and not some other problem.
Xfire68 is offline  
Old July 6, 2010, 12:10 PM   #6
Unclenick
Staff
 
Join Date: March 4, 2005
Location: Ohio
Posts: 10,308
Ah, got it. I assumed the parts were intact. Yes, you need enough spring pressure to push the sear back. It will affect trigger pull weight but you need enough pressure to function.
__________________
Gunsite Orange Hat Family Member
CMP Certified GSM Master Instructor
NRA Certified Rifle Instructor
NRA Benefactor Member
Unclenick is offline  
Old July 6, 2010, 12:22 PM   #7
Xfire68
Senior Member
 
Join Date: March 31, 2010
Location: Communist State of IL.
Posts: 1,428
I shot it yesterday and for the most part it work fine but there where a few full trigger pulls out of 75 or so rounds? I ordered the spring and some other spare parts so if I screw things up again I can replace the parts if needed. Thanks again for the help!
Xfire68 is offline  
Old July 6, 2010, 08:08 PM   #8
James K
Staff
 
Join Date: March 17, 1999
Posts: 19,646
It sure would be nice if folks were honest enough to start with "I took my gun all apart and messed with the parts and now...."

That at least would let us know where things stand and give us more info on which to base advice.

Jim
__________________
Jim K
James K is offline  
Old July 6, 2010, 09:30 PM   #9
Xfire68
Senior Member
 
Join Date: March 31, 2010
Location: Communist State of IL.
Posts: 1,428
I got the answer I needed. Pretty simple was it not? Sounds like you want it to be more complicated?
Xfire68 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07541 seconds with 9 queries