The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old December 17, 2009, 03:00 AM   #1
Closure
Junior Member
 
Join Date: December 13, 2009
Posts: 7
1911 Assembly problem

First, a little bit of an introduction: I'm a beginner firearm owner and have just began the learning process of field stripping and cleaning. I recently splurged on a Kimber Custom II and after the range, went about field stripping and cleaning.

The problem that I am having is that when I fully reassemble the firearm, the slide will not lock back, and the chamber indicator port is always showing.

Edit: Solved the problem putting the putting the magazine back in. Sorry for wasting a post, but hey, everyone's gotta start somewhere.

Last edited by Closure; December 17, 2009 at 03:26 AM. Reason: Would help if I put the magazine back in.
Closure is offline  
Old December 17, 2009, 09:48 AM   #2
brickeyee
Senior Member
 
Join Date: December 29, 2004
Posts: 3,342
As you have now learned, the slide stop is actuated by the magazine follower of an empty magazine.

There is enough clearance that a round in the mag does not catch the slide stop, but the follower will one the round is gone and the follower rises to tthe very top of the mag.
brickeyee is offline  
Reply

Tags
field strip help

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06662 seconds with 7 queries