The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old August 24, 2009, 10:29 PM   #1
BoB_25
Junior Member
 
Join Date: December 7, 2008
Location: NE
Posts: 1
Xtrema 2 Help Question

I recently purchased a Xtrema 2. I took it apart cleaned it and oiled it up before I took it out for it's first test fire. Shot 250+ rounds with no problems. Took it apart and cleaned it again and went out and shot 10 more times. Just to make sure I did it right. Then cleaned it again and put it away. The other day I took it out and fired 125 rounds through it with no problem again. I went to take it apart to put it back in the case to go home and notice there a plastic o-ring on the magazine tube that I don't remember before. Is that right or did something happen? I can't find anything in manual about it.

Thanks in advance.

Nate
BoB_25 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05351 seconds with 7 queries