The Firing Line Forums

Go Back   The Firing Line Forums > The North Corral > Curios and Relics

Reply
 
Thread Tools
Old March 20, 2009, 05:20 PM   #1
mp25ds4
Senior Member
 
Join Date: March 6, 2009
Posts: 392
mosin wont take cleaning rod

Hello, I was recently given a 1943 91/30 mosin nagant that my uncle picked up in vietnam that didnt come with a cleaning rod and whenever i try to put one in off of my other mosins it wont go in all the way and it sticks out about 3" past the tip of the barrel. I dont know if there is alot of dirt in the threads or what? any suggestions on what I could do to try to get the cleaning rod in?
mp25ds4 is offline  
Old March 20, 2009, 05:52 PM   #2
ar15chase
Senior Member
 
Join Date: February 20, 2009
Location: Shallowater, Texas
Posts: 444
Did you remove the bolt and look down the barrel?
ar15chase is offline  
Old March 20, 2009, 06:01 PM   #3
XLT
Senior Member
 
Join Date: January 20, 2005
Location: El Paso, TX
Posts: 207
I don't think he means that it sticks out of the barrel...it just sticks outside the barrel...

I was reading something recently, about removing and installing the cleaning rod nut in the stock on a mosin nagant. I will try and dig it up.
__________________
It's a shame all my guns were with Trapp's...
XLT is offline  
Old March 20, 2009, 06:04 PM   #4
ar15chase
Senior Member
 
Join Date: February 20, 2009
Location: Shallowater, Texas
Posts: 444
OOOOH I can see that now. Misunderstood. I will check into it also.
ar15chase is offline  
Old March 20, 2009, 06:09 PM   #5
ar15chase
Senior Member
 
Join Date: February 20, 2009
Location: Shallowater, Texas
Posts: 444
I just got off the phone with a buddy of mine who shoots m-44's a lot. He said if its not threading down, to take a 17hmr brush soaked in WD-40 and gently work it around, blow it out with an airhose and repeat. Maybe that will help.
ar15chase is offline  
Old March 20, 2009, 08:44 PM   #6
mp25ds4
Senior Member
 
Join Date: March 6, 2009
Posts: 392
Ok thanks man I really appreciate it
mp25ds4 is offline  
Old April 17, 2009, 01:17 PM   #7
Randy Miller
Junior Member
 
Join Date: January 16, 2008
Location: Austin, Tx
Posts: 7
I had the same problem with my M44...there is a nut inside of the stock that the cleaning rod threads into to hold it into place. I actually had to remove the nut from the stock and clean it out. The hole was a packed full of dirt so the rod wouldn't thread......
Randy Miller is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06560 seconds with 7 queries