The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old March 7, 2009, 12:48 AM   #1
Mandrake
Junior member
 
Join Date: March 7, 2009
Posts: 37
Winchester 1200 Malfunction

Gentlemen,
I recently bought a used Win. 1200 and took it out for the first time today. It shot fine but after pulling the trigger the forearm would slide back on its own and get locked in the rear position. I would then have to push the action release button again to put it back into the front position thus ejecting out both the used shell and the new shell.
In short it was a real pain in the ass. So is this a Winchester thing or did I get sold a defective shotgun?
Any of you guys know what this could be? Really put a damper on my shooting day. On the bright side, my brand new Glock23 shot like a true champion.

Mandrake
Mandrake is offline  
Old March 7, 2009, 04:52 AM   #2
xm21
Senior Member
 
Join Date: April 29, 2008
Posts: 177
Assuming you shoot right handed where was your left hand when this was happening?Sounds like the gun is operating like it is supposed to,try holding on to the forearm with a firmer grip,that is odd about having to use the release to get it forward,it's function is to release the bolt when it is in battery without pulling the trigger.

Last edited by xm21; March 7, 2009 at 05:02 AM.
xm21 is offline  
Old March 7, 2009, 07:33 AM   #3
jughead2
Senior Member
 
Join Date: June 28, 2008
Location: tenn.
Posts: 204
winchester

seems like they all do it except locking back if one doesnt hold on to the slide with a firm grip. have talked to several people that have the same problem. i personally dont like it but dont have a remedy.
jughead2 is offline  
Old March 7, 2009, 10:00 AM   #4
delzo
Senior Member
 
Join Date: March 30, 2005
Location: Knee deep in Galveston Bay
Posts: 144
I've got a Police Stainless built from the 1200 and have never had that happen in hundreds of rounds. The action is designed to release after a shot and it almost feels like it wants to cycle itself..... but mine never locks open.

Something is not right.
delzo is offline  
Old March 7, 2009, 11:47 AM   #5
Mandrake
Junior member
 
Join Date: March 7, 2009
Posts: 37
Thanks dudes, I'm gonna try and go out again and see if it was just my technique. Maybe I was limpwristing the forearm a little too much. I'll try a firmer grip and see how it goes.
Mandrake is offline  
Reply

Tags
defender , malfunction , winchester 1200

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07046 seconds with 7 queries