The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old January 12, 2009, 03:09 PM   #1
cmacjvan
Junior Member
 
Join Date: January 12, 2009
Posts: 1
Winchester Model 50 Question

When I fire my Winchester Model 50 it cycles and fires the second shell IMMEDIATELY following the first shot. In other words it fires two shells as if it were a fully automatic weapon. Does anyone know what needs to be done to fix this? I have had the gun since new in 1958, but I know it has fewer than 1000 rounds fired in that time.
cmacjvan is offline  
Old January 13, 2009, 02:41 PM   #2
dgludwig
Senior Member
 
Join Date: February 12, 2005
Location: North central Ohio
Posts: 5,182
I'm just wondering if you're inadvertently leaving your finger on the trigger after the initial shot, and applying just enough pressure to fire the second shot.This would even more likely be the case if you were wearing gloves at the time. But, because you've had the gun for so long and are no doubt very familiar with it, my guess is a defective disconnector.
__________________
ONLY AN ARMED PEOPLE CAN BE TRULY FREE ; ONLY AN UNARMED PEOPLE CAN EVER BE ENSLAVED
...Aristotle
NRA Benefactor Life Member
dgludwig is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05872 seconds with 7 queries