The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old December 6, 2008, 01:00 AM   #1
McBrideGuns
Member
 
Join Date: January 6, 2006
Location: Mississippi
Posts: 77
11-87 sportsman problem

Just curious if anyone out there has run into this problem and may know how to fix it. I’ve recently been shooting my 11-87 and I turn it over to where I'm looking at the loading gate with the chamber open and the gun empty and without ever touching anything the chamber will slam shut on me now correct me if I’m wrong but I do not believe it is supposed to do this is and I’m wondering if anyone can tell me how to fix it I sent it back to Remington right after I got it for this same problem and they told me that I was just putting my plug in backwards which I know isn't the problem because the gun does this even when the plug isn't in it has anyone else had this problem and know how to fix it?
McBrideGuns is offline  
Old December 6, 2008, 09:49 PM   #2
nutty ned
Senior Member
 
Join Date: November 26, 2006
Posts: 765
It has to be the carrier assembly, probably a spring is faulty.
See if there is a Remington warrenty repair dealer nearby and discuss it with them.
nutty ned is offline  
Old December 6, 2008, 11:46 PM   #3
McBrideGuns
Member
 
Join Date: January 6, 2006
Location: Mississippi
Posts: 77
Ok I will do that thank you very much for your help.
McBrideGuns is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05592 seconds with 7 queries