The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Thread Tools Search this Thread
Old March 21, 2008, 03:20 PM   #1
Junior Member
Join Date: October 28, 2006
Posts: 4
My S&W model 17 has a trigger problem

The trigger will operate if pulled fast, but, it will stop early in the cycle if pulled slowly. Does anyone have an idea of the cause of this? This problem just started after several years of normal double action shooting. The single action operation of the revolver is normal. Thanks for your thoughts on this,
lumpychicken is offline  
Old March 21, 2008, 07:12 PM   #2
Senior Member
Join Date: May 4, 2001
Posts: 6,977
There's just too many things it could be to diagnose without seeing it.

Possible problems range from a broken hammer surface, a gummed up, worn, or broken double action strut, to ??????

I recommend seeing a good gunsmith, or send it in to S&W.
Dfariswheel is offline  

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 06:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2016 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent:
Contact Us
Page generated in 0.05108 seconds with 9 queries