The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old March 11, 2006, 09:00 PM   #1
KS1911
Member
 
Join Date: February 18, 2006
Posts: 53
Kimber 84M .308, Need Help

I purchased the above rifle this week. Went out to shoot it the next day and loaded 3 rounds into it. After firing the very first one, I was unable to pull the bolt back. It would rotate up but would not come back. I unloaded the 2 remaining rounds from the floorplate but I still could not pull it back. I had to go home and stand the rifle up on a chair while pushing down on the bolt with all my force to free it. I found that the casing had two black residue rings around it so I cleaned the rifle and took it out again the next day. Now the jams will happen every 6 or so rounds but only so far when 2 other rounds are loaded into the floorplate. Also, at times, after loading a round, it will not fire when the trigger is pulled. I can hear it click like a dry fire but nothing. I simply have to lift the bolt then lower it again to correct this. Any advice? A brand new Kimber rifle should not be doing this, especially for the price. My cheap savage never did.

Thanks,
KS1911
KS1911 is offline  
Old March 12, 2006, 03:36 AM   #2
Wildalaska
Junior member
 
Join Date: November 25, 2002
Location: In my own little weird world in Anchorage, Alaska
Posts: 14,174
What ammo are you using?

WildstayoffofthechairAlaska
Wildalaska is offline  
Old March 12, 2006, 03:59 AM   #3
KS1911
Member
 
Join Date: February 18, 2006
Posts: 53
Hornandy Custom 150 Gr. SST
KS1911 is offline  
Old March 12, 2006, 04:07 AM   #4
Wildalaska
Junior member
 
Join Date: November 25, 2002
Location: In my own little weird world in Anchorage, Alaska
Posts: 14,174
Send it back to Kimber

WildeasyanswerAlaska
Wildalaska is offline  
Old March 12, 2006, 04:28 AM   #5
DWARREN123
Senior Member
 
Join Date: January 22, 2006
Location: BETWEEN TN & KY
Posts: 1,759
Yes, let Kimber know because this is/can be dangerous and is not what you payed for!
DWARREN123 is offline  
Old March 12, 2006, 10:04 AM   #6
KS1911
Member
 
Join Date: February 18, 2006
Posts: 53
That was my plan of action but I wanted to check first to be sure it wasn't an easy fix so I did not have to send my new rifle off for fixing this quickly.
Thanks for your help.
KS1911 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06769 seconds with 7 queries