The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old March 24, 2000, 01:34 AM   #1
samsonj
Member
 
Join Date: March 19, 2000
Posts: 23
I have a Ruger P90, I have only fired around 1000 rounds through it. It does really good , except today when I was shooting it the slide did not return all the way back to home position, or fully forward after a shot.
My first question is what could cause this?
I clean the weapon after every use.
What do I need to do, or change?
Is this a common problem?
samsonj is offline  
Old March 24, 2000, 07:14 AM   #2
Desert Dog
Senior Member
 
Join Date: September 22, 1999
Location: Dallas, TX
Posts: 473
You need to describe more of your problem. Does it not close all the way when feeding only? Does it not close all the way when empty also?? Give me more info and I can probably help you. How many rounds between cleaning?

No this is NOT a common problem. My '90 has NEVER mis-fed or failed to fire. Do you use gun grease? I recommend Tetra, darn good stuff.

back at ya, big guy...

------------------
.45 Super... Fat and FAST...

"No provision in our Constitution ought to be dearer to man than that which protects the rights of conscience against the enterprises of the civil authority" - Thomas Jefferson

[This message has been edited by Desert Dog (edited March 24, 2000).]
Desert Dog is offline  
Old March 24, 2000, 07:40 AM   #3
samsonj
Member
 
Join Date: March 19, 2000
Posts: 23
Hi Desert Dog,
Thanks for reading my thread. The problem has only happened one time. The gun has not miss fired, it did not jam,"I don't think.
To me it acted like the return spring was not strong enough for the gun, or the slide rail was dry. All I did was help the slide the rest of the way home.
With no rounds in the clip the slides has no problem returning home, atleast not yet.
Grease?, all I have used is standerd gun oil and solvent. Is this grease expensive, I guess that is a non-issue. I mean no matter what its costs if it is neaded I will do what I have to to get what I need.
I clean the gun after very outing, usually 100+ rounds are put through it at a session.
I hope this info helps. Thanks again.
JsJ

------------------
one shot one kill
samsonj is offline  
Old March 24, 2000, 09:11 AM   #4
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Samsonj, 9 times out of 10 this is caused by something, dirt etc., in the chamber or bulged reloads. If the pistol was new I'd say there was a chance that the barrel had not been properly fitted but since it has over 1000 rounds through it that's not probable. George
George Stringer is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05919 seconds with 7 queries