The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old January 9, 2000, 07:22 PM   #1
Macoute
Member
 
Join Date: October 9, 1998
Posts: 24
The cylinder on my SP101 (9mm) locks up when I try to thumb cock it for SA fire. It only does this on one cylinder stop, but does it consistently. The cylinder locks up completely when I try to thumb cock it, but will cycle when I pull the trigger for DA fire. I have examined the stop on the cylinder and the ratchet and cannot find any burrs or other problems. This just started after my last range session. I have disassembled it a few times to see if something was out of place and have not found anything. Does anyone have nay ideas before I make a trip to the local gunsmith or send it off to the factory? Thanks.
Macoute is offline  
Old January 9, 2000, 11:45 PM   #2
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Macoute, if the gun is still under warranty send it back. If not take it to your local smith. I could be wrong but it sounds more like a timing problem to me and this won't be something you can take care of at home. George
George Stringer is offline  
Old January 9, 2000, 11:49 PM   #3
James K
Staff
 
Join Date: March 17, 1999
Posts: 18,670
It sounds like the cylinder stop may be coming back up and locking the cylinder before it can turn. If it does this on one chamber, it is very close to doing it on all. You can check this by looking through the gap at the bottom of the cylinder and watching the cylinder stop.

If this is the problem, you can try disassembling the gun and giving it a good cleaning and also checking out the cylinder stop spring; one too light can cause that problem.

If you are not sure how to disassemble that gun, take it to a smith. It sounds easy when they say it fast.

Jim
James K is offline  
Old January 10, 2000, 11:14 AM   #4
Kernel
Senior Member
 
Join Date: November 21, 1999
Location: Madison, WI.... "78 Square Miles Surrounded by Reality"
Posts: 922
Send it back to Ruger and they'll fix it for free (I think they do charge $10 for S&H). I've sent a number of Rugers I bought used back to factory for service and was never charged for any of the repairs. One was a Super Blackhawk that the previous owner had put a spring kit in it and tried to do a "trigger job" on it. It was all messed up and would barley even function. Sent it off to Ruger, it came back in about 6 weeks with a new trigger, hammer, springs, transfer bar, nummerous internal parts, and new front & rear sight(!!). The new trigger pull was very nice, a crisp 4.5 to 5 lbs. Perfect for a hunting revolver. Didn't cost me a thing. -- Kernel
Kernel is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05713 seconds with 7 queries