The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old December 20, 1999, 12:42 PM   #1
Chad Young
Senior Member
 
Join Date: September 20, 1999
Location: Gainesville, FL
Posts: 601
I recently purchased 100 rounds of PMP (South African manufacture) ammo for a recently acquired rifle. This stuff is 130-grain soft point new ammo in the box. I am having some unique problems with it, however.

First, let me give you the specs on the gun:
Remington model 7400, caliber .270 Winchester. Previously had been fired a total of 10 rounds. Unit was clean, oiled, properly broken in, and chamber was spotless.

The problem was this: I load the mag, cycle the action, pull the trigger, gun goes bang; however, the case stays in the chamber! Instead of the round popping out, the chunk of case rim under the extractor broke off and the round stayed put. A very light tap with a cleaning rod popped the case out easily. I figured it was perhaps one bad case, so I stuck in another round. Same thing. This time, the case simply dropped out the chamber when I tilted the gun back. I finished the rest of the day with ten rounds of remington .270 and had no problems. (Got about 2" groups at 100 yards, no less!)

My questions are:
1. Anyone else have problems with PMP ammo?
2. Is this perhaps a problem with the rifle?
3. If I cannot get this rifle to digest the PMP ammo, anyone want to buy some cheap .270? : )


Chad Young is offline  
Old December 20, 1999, 11:54 PM   #2
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Chad, try some different ammo. It sounds like the rounds you're using are two high pressure for the gun. These rifles are timed and tuned to work within certain pressure limits. In other words if it works with standard factory ammo the PMP is putting too much gas through the sytem and the bolt is working too fast. George
George Stringer is offline  
Old December 21, 1999, 08:40 AM   #3
Chad Young
Senior Member
 
Join Date: September 20, 1999
Location: Gainesville, FL
Posts: 601
Thanks for the input. I found that when I switched ammo brands to Remington Core-Lokt 130 grain loads, the rifle functioned perfectly. I was concerned that the cases on the PMP rounds were defective, but it would seem more logical that the rounds may be a little too hot for the model 7400. Anybody want some .270 for their bolt action rifle, cheap?

Chad Young is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06365 seconds with 9 queries