The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old June 21, 1999, 04:42 PM   #1
PKAY
Senior Member
 
Join Date: March 22, 1999
Location: L.A., CA, USA
Posts: 911
I have a police trade in factory refurbished Glock 17 with hi-cap mags. The weapon functions flawlessly after thorough cleaning up through 200 rounds. After that I begin to get misfires. The ammo misfiring are not duds. But I have noticed all misfiring rounds show the dimple imprint from the firing pin way off on the edge. All firing rounds show the dimple virtually dead center in the primer. Also, if I reload the dud rounds in an empty magazine, load the pistol and fire, they all fire off without mishap. Any ideas? Could it be a bad firing pin? Is the slide not returning to full battery? Thanks for your help.

------------------
Safe shooting - PKAY
PKAY is offline  
Old June 21, 1999, 08:02 PM   #2
blades67
Senior Member
 
Join Date: April 22, 1999
Location: Chandler, Arizona, USA
Posts: 6,014
Are you using factory ammo? If you're using reloads they may be sized incorrectly and preventing the slide from going into battery when the chamber becomes foaled. It could also be the extractor. If the round is in front of the extractor (Glock pistols will, and do, fire slightly out of battery), this may explain the off center primer hits. As to why the brass would still eject, the blowback would cause the brass to strike the ejector and exit as you would expect.
I would try several other factory loads. If the problem persists, unload and clear the weapon and take it to a gunsmith. Or call Glock to get their feedback.

------------------
~Blades~
blades67 is offline  
Old June 21, 1999, 10:27 PM   #3
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Pkay, I think Blades nailed this one. Give your chamber a good scrubbing and try some different ammo as he suggested and I'd almost bet that you'll save yourself that trip to the smith's. George
George Stringer is offline  
Old June 22, 1999, 10:32 AM   #4
PKAY
Senior Member
 
Join Date: March 22, 1999
Location: L.A., CA, USA
Posts: 911
Blades and George, thanks for your replies. The ammo I am using is reloaded hard ball (FMJ) to factory specs. by Miwall in Grass Valley, CA. I have used this stuff for years in all my 9 mm pistols without incident. However, your advice is well taken, and I shall try some factory fresh rounds to see if I can replicate the problem. Based on your comments, it would appear fouling in the chamber may be the culprit. When at the range, I shoot at least 350 rounds through whatever I take, so maybe I'm just "gunking" it up. Thanks again for your help.

------------------
Safe shooting - PKAY
PKAY is offline  
Old June 22, 1999, 06:41 PM   #5
James K
Staff
 
Join Date: March 17, 1999
Posts: 18,647
I, too, suspect the gun is not going fully into battery, with the result that the firing pin strike is high on the primer and will sometimes cause a misfire. Other than cleaning the chamber, it is possible that the batch of ammo you are using is slightly oversize at the case mouth or the bullets are of a different shape or seating depth than what the reloader was using.

Jim
James K is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07289 seconds with 7 queries