The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old November 7, 2005, 07:25 PM   #1
kb1966
Junior Member
 
Join Date: November 7, 2005
Posts: 4
franchi not ejecting

I have a franchi 20 ga mod 48 black magic , its got about 1500 rounds on it and its a decent gun but latley it has stopped ejecting and no matter how clean it is it dosent help . Plugged gas port ? worn slide ? light loads ?
kb1966 is offline  
Old November 7, 2005, 09:04 PM   #2
cntryboy1289
Senior Member
 
Join Date: July 19, 2004
Location: Ms
Posts: 1,160
check the ejector

The ejector is most likely either broke or has a problem. It could be loose or just rounded over.
cntryboy1289 is offline  
Old November 7, 2005, 10:50 PM   #3
kb1966
Junior Member
 
Join Date: November 7, 2005
Posts: 4
Franchi

hey thanks but I already checked the ejector and physically it looks ok and if I pull the bolt back fast it will toss the shell pretty far.Everything seems to move , slide , click and cock normally. the gun has been kept clean through its life. There are a couple of things Im not sure of though.

1) The gas tube for the recoil . Does it have one ? Where ?

2) The position of the bushing that holds the tube spring
kb1966 is offline  
Old November 7, 2005, 11:32 PM   #4
cntryboy1289
Senior Member
 
Join Date: July 19, 2004
Location: Ms
Posts: 1,160
mmm

Well, without looking at the actual gun this one is a little harder to figure if you say it ejects when you pull the bolt back by hand fast. Most shotguns use a gas port under the barrel band, I wouldn't think it is dirty and causing you problems, but without seeing the gun and knowing what kind of loads you have shot through it or knowing whether you get it extremely wet and dirty at times it is hard to say.

Does the round just sit on the bolt face or does it fall down into the opening of the receiver?

What does the manual say about shooting light loads? Some guns need to be changed up when they shoot light loads. I am not familiar with a Franchi enough to know for sure. If it is set up for heavy loads the way it sits now, it may not have enough pressure to push the bolt fact far enough to eject the round. Read up on it and see to know for sure. Some guns can't shoot light loads the way they are set up. That may be the problem here.

It may be the extractor is turning loose of the rim before the ejector gets to push it out. Check out the extractor and make sure it will push back against the bolt like it should. If it's not, that is probably it. If that's not the problem, take it to a smith or send it back and let Franchi check it out for you.
cntryboy1289 is offline  
Old November 8, 2005, 12:35 AM   #5
kb1966
Junior Member
 
Join Date: November 7, 2005
Posts: 4
Ive always used trap or light game loads in this gun. its only chambered 2 3/4
so its never seen a " heavy " load .
As far as the eject it is not always the same sometimes it will try to fall into the receiver ,other times it seems as though the bolt doesent open at all ,
Still other times it will turn the empty so that the plastic it sticking out at a 90 to the gun.
Ive always kept this particular gun clean / dry and been kinda anal about it I paid a good buck for it and babied it. If compared to the way I treat my R-10-22 or Ithica skb .
Ive Got the link now and will look up the diagram . Thanks for your input.
Now that Ive got a print Ill be burnin rounds in no time
kb1966 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06251 seconds with 7 queries