The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old June 15, 2013, 03:31 PM   #1
01frida
Member
 
Join Date: July 21, 2010
Posts: 26
Ruger LC9 Clip Problem

Just purchased a new LC9 for the wife and off to the range. Second clip she shot the clip released while she was shooting. I told her she was hitting it with her thumb because of the way she held it (she has carried a 38 colt snubby for years). I was wrong.... you can jiggle the clip and it will release. The clip appears to be OK with no denting in the keeper notch. I tried to purchase a different clip from the range but they didn't have one. I am not sure if it is the clip or the keeper / release mech. Thoughts appreciated before I send back to Ruger. Bummer...
01frida is offline  
Old June 15, 2013, 03:42 PM   #2
tobnpr
Senior Member
 
Join Date: August 1, 2010
Location: Tampa Bay
Posts: 3,127
Not much there...
Did your field strip it and take a look at how the mag is mating up with the mag latch and spring? Gotta be the mag, or the latch...
__________________
Custom Bent Bolts and Gunstocks for the Mosin-Nagant
www.biggorillagunworks.com
tobnpr is offline  
Old June 15, 2013, 03:53 PM   #3
g.willikers
Senior Member
 
Join Date: September 28, 2008
Posts: 5,325
Is the magazine release overly easy to depress?
If so, maybe the spring is either weak or even missing.
__________________
Lock the doors, they're coming in the windows.
g.willikers is offline  
Old June 15, 2013, 03:57 PM   #4
01frida
Member
 
Join Date: July 21, 2010
Posts: 26
yes I did, I even measured the distance of the mag to the keeper latch and it looks good. It will engage but if you jiggle it a little it will release. The keeper looks like it is traveling all the way into the grip compartment so I thought it could have been the clip. Gun shoots great and she is very good with it so I need to figure it out. Appreciate the reply
01frida is offline  
Old June 15, 2013, 03:57 PM   #5
Roughedge
Senior Member
 
Join Date: January 24, 2011
Location: Monroe,NC
Posts: 367
Does a empty magazine do the same thing ? Take the slide off and see if you can see the engagement when you insert the magazine.
__________________
The man that die's with the most stuff win's!
Roughedge is offline  
Old June 15, 2013, 04:01 PM   #6
01frida
Member
 
Join Date: July 21, 2010
Posts: 26
The release button feels OK when depressed and goes back to the correct position.. spring feels right. Also, yes it will do it with an empty clip as well. I thought about putting a little pressure on the keep slot but decided not to as it looks to be inline and ok. Maybe I should send it back to ruger but may try a different clip first.

Last edited by 01frida; June 15, 2013 at 04:15 PM.
01frida is offline  
Old June 15, 2013, 11:16 PM   #7
Loronzo
Member
 
Join Date: July 1, 2012
Posts: 93
Funny thing but I bought a new magazine for my fiancee's LC9 and the last time we went to the range with the new mag it did the exact same thing, I too thought she was hitting the mag release button. (She never had problems with the original one). I thought it was just a problem with the mag but now after reading this thread I think we will be calling ruger and sending them the pistol and both mags...
Loronzo is offline  
Old June 16, 2013, 08:56 AM   #8
01frida
Member
 
Join Date: July 21, 2010
Posts: 26
Thanks for sharing. I am sending this one back as well. Looks like they (or we) have a problem. Appreciate all the input
01frida is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.09248 seconds with 9 queries