The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old January 18, 2013, 03:03 PM   #1
srfisher3
Member
 
Join Date: November 3, 2012
Posts: 17
AR feed issues

I recently installed a new heavy barrel on my AR. I put on a new gas block(GB systems) and a new gas tube. About two weeks ago, I took the rifle to the range for its maiden voyage. The first 2-3 rounds went fine however, the weapon began failing to feed. It would extract just fine but the bolt wasn't picking up a new round. I figured I had missaligned the gas block so I took it back to my house and tweaked it. I fired it at the range today but had similar problems. This time, I was able to fire about 15 rounds without an issue before it started failing to feed. The gas block made by GB systems is now discontinued so I'm hoping its just a poor quality gas block...

A friend of mine mentioned it was possible the new barrel I purchased may have an issue in the chamber. He said as the metal in the chamber heats due to firing, it could be causing the malfunction. I'm looking for some direction on how to fix this myself. Thanks
srfisher3 is offline  
Old January 20, 2013, 10:22 AM   #2
oryx
Senior Member
 
Join Date: December 26, 2008
Posts: 140
Hard to tell whether it is short stroking from a gas system issue or a mag isssue or chamber issue.
It does sound like your issue did get better when you tweaked your gas block, and being that it is not picking up the next round it may be short stroking. So it maybe the gas block alignment. It may help to chamfer the gas block hole slightly to help alleviate alignment issues.

Hope you getting straightened out
oryx is offline  
Old January 20, 2013, 04:25 PM   #3
DnPRK
Senior Member
 
Join Date: August 24, 2001
Location: LC, Ca
Posts: 1,756
You have to aligh the barrel gas port with the gas port in the gas block in the left/right and fore/aft directions.

Most people know about left/right indexing, but some don't realize that gas blocks come in versions to be used with and without hand guard retainers. This can cause an 0.030" fore/aft mismatch and partially blocked gas port.
DnPRK is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05797 seconds with 9 queries