The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old January 29, 2000, 07:37 PM   #1
fyrfytrj
Member
 
Join Date: December 29, 1999
Posts: 27
i just bought a NIB mossberg 590. I got it home and loaded up the tube, and then began to cycle it (pump it). It failed to feed at least 1/3 of the time. The new shell would not release out of the tube. I removed the spring and reinstalled it and FTF. I tried to call Mossberg but they were closed for the weekend... Help please?????????????any suggestions on what I can do. I can fix it if you can explain it....thank you
fyrfytrj is offline  
Old January 29, 2000, 09:18 PM   #2
pete80
Senior Member
 
Join Date: July 4, 1999
Posts: 454
Wait till' Monday?

It might be a bad mag spring or faulty magazine follower. This might sound dumb but are the shells 12 gauge? Are they 2 3/4" or 3"? Maybe the shells are too large, different gauge.
pete80 is offline  
Old January 29, 2000, 11:44 PM   #3
jcoyoung
Senior Member
 
Join Date: January 20, 2000
Location: Oak Forest, IL
Posts: 661
I also have a 590 (parkerized) and I haven't had any problems at all.

This may sound silly, but did you clean everything first? Be sure to clean the bbl and magazine tube according to the instructions. You can also try cleaning and oiling all the intenal parts. You may want to pay particular attention to the cartridge interrupter and cartridge stop. (p10 in the manual)

Good luck!
jcoyoung is offline  
Old January 30, 2000, 10:01 AM   #4
Ned Roundtree
Senior Member
 
Join Date: December 8, 1999
Location: Lexington, KY,USA
Posts: 738
Ditto, jcoyoung comments. When you take a new gun or used gun outa the box. The first thing you do is clean it for the factory grease and packing my still be in it. It may look clean. But it really has to be cleaned first!!
Ned Roundtree is offline  
Old January 30, 2000, 02:11 PM   #5
Dave McC
Staff In Memoriam
 
Join Date: October 13, 1999
Location: Columbia, Md, USA
Posts: 8,812
I'm no expert on Mossbergs, but try this...

With an empty weapon,hold the slide release down and keep cycling the action until your arms get tired,then do it again when your rested.Clean and lube.

Load up with some dummy shells if you have them and see if it's improved.IMO, there's a good chance it has...
Dave McC is offline  
Old January 31, 2000, 11:13 PM   #6
ctdonath
Senior Member
 
Join Date: April 11, 1999
Posts: 1,902
My 590 was totally dry when I got it; absolutely no lubrication. Didn't help that I didn't notice until the forend got really hard to move. A good dose of oil and a few hundred cycles fixed it nicely.
ctdonath is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07877 seconds with 7 queries