The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old December 27, 1999, 09:55 PM   #1
creekchub2
Junior Member
 
Join Date: December 27, 1999
Location: Georgia
Posts: 5
Hello, I am new to this forum but I have found good advice and info about other activities and topics on other UBB style forums. There seems to be allot of experience and information available from members. I have searched the archives to no avail for information about the following situation.

We recently purchased a 20 ga. Beretta A303 for my wife. It was a previously owned but never fired weapon. When we tried to fire it for the first time we had problems with shell ejection and shell advance. We had this problem with only one shell in the chamber and when there was one chambered shell along with two magazined shells. It seems that the gas piston system is not functioning properly. We had to manually pull back on the cocking handle to open the breech bolt and eject a shell. We fired it only a few times before stopping, realizing this was NOT a good situation. Once, the breech bolt partially retracted and the ejection port was about 70% open but it never cycled properly.

What gives? It is assembled properly. The gun sat unused in original box for about 10 years prior to our purchase and use. We aren't getting much information from the scant, poorly translated English portion of the manufacturers "manual". Does it need some specific lubrication due to length of time in storage? We also had some problem with the cut off functioning properly while familiarizing ourselves with the gun while it was unloaded. Any help would be appreciated. We are new to semi-auto shotguns (...OK fairly new to shotguns in general - although I HAVE figured out my Mossberg 500 pump!).

T.I.A.
creekchub2 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.04443 seconds with 7 queries