The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old November 2, 2001, 09:33 AM   #1
RBK
Registration in progress
 
Join Date: September 26, 2000
Location: East TN
Posts: 352
Is This Normal for a Model 12?

I have an old Winchester Model 12, 16 ga. that chambers, feeds, shoots and extracts great. Only thing I wonder about is the loading. When inserting the shells following the first into the magazine, the others want to come back out. That is to say, the first shell clicks in OK but as soon as the second shell begins pushing the first, the first starts backing out. And so on with all of the remaining shells. By the time I have the 7th shell in, it is big time resistance. Everything in the loading mechanism seems to be in tact. Is this behavoir normal for a Model 12?
RBK is offline  
Old November 2, 2001, 12:06 PM   #2
Dave McC
Staff In Memoriam
 
Join Date: October 13, 1999
Location: Columbia, Md, USA
Posts: 8,812
Sounds like a worn shellcatcher. Take it to a reputable smith who'll fix it and make it work for another half century....
Dave McC is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05910 seconds with 9 queries