The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Art of the Rifle: Bolt, Lever, and Pump Action

Reply
 
Thread Tools
Old April 8, 2013, 04:56 PM   #1
jimaw2
Member
 
Join Date: October 2, 2008
Location: n california
Posts: 83
rossi m92 problem

i recently purchased a m92 rossi .357 trapper. after 40 or 50 trouble free firing the action locked up. i noticed that the loading gate was almost flush with the receiver and when i depressed it, the action cycled. i checked the screws and found the screw behind the gate was loose. another 10 or so shots with no problem. took it out again today and we are having the same issue. it may be more likely to happen when the mag is close to full capacity, but i was not able to shoot it enough to be sure. has anyone run into this and found a solution? it is a new rifle, but i'm not going to ship it back for a "problem" they probably won't be able to duplicate. thanks for your input.......
jimaw2 is offline  
Old April 9, 2013, 09:55 PM   #2
DnPRK
Senior Member
 
Join Date: August 24, 2001
Location: LC, Ca
Posts: 1,773
The screw directly aft of the loading gate secures the loading gate to the receiver.
The screw directly above the loading gate holds the right cartridge guide.
The screw below and slightly aft of the loading gate holds the right side of the carrier/cartridge lift.
DnPRK is offline  
Old April 9, 2013, 10:12 PM   #3
Hawg
Senior Member
 
Join Date: September 8, 2007
Location: Mississippi
Posts: 11,808
If it keeps working loose use some blue loctite on it. Don't use red tho.
Hawg is offline  
Old April 14, 2013, 12:26 AM   #4
jimaw2
Member
 
Join Date: October 2, 2008
Location: n california
Posts: 83
Ok, after fooling around with this thing I have determined that the problem is not double feeding. I can see that the next round in the mag tube is being held back as it is suppose to be. when the jam occurs something is pushing the loading gate out as I close the action. any ideas?
jimaw2 is offline  
Old April 16, 2013, 12:59 AM   #5
jimaw2
Member
 
Join Date: October 2, 2008
Location: n california
Posts: 83
well, a little update if anyone finds themselves with the same problem it turns out the spring cover for the loading gate was not manufactured properly. it was too short and allowed the cover to move into the loading gate which jammed the action. I found lots of articles on ftf on this rifle, but only one which dealt with my problem. rossi is sending me a new one for no cost and I have "fixed" the old one with a well aimed center punch. works great for now!
jimaw2 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06989 seconds with 9 queries