The Firing Line Forums

Go Back   The Firing Line Forums > Hogan's Alley > Handguns: The Semi-automatic Forum

Reply
 
Thread Tools
Old April 11, 2013, 07:28 PM   #1
ejfalvo
Senior Member
 
Join Date: February 8, 2009
Posts: 239
XDs ammo issue.

Had the XDs since it became available and shot WWB, Magtech, Remington, Horaday, etc thru it with no problem. Currently run Speer Gold as SD ammo, never a problem with FTE, FTF. Yesterday at the range, saw RWS ( orange and black box) ammo, bought a box and loaded the magazine. Pulled the trigger and first round went fine, then click, click, click. Pulled the mag, looked at the unfired round and there was a good dimple in the primer. Tried it again, same problem. Round one went fine, the nothing. Freaking out, replaced the RWS with Hornaday CD and bang, bang, bang, etc. all the RWS rounds that didn't fire had good, deep dimples where the firing pin struck.

Took the RWS back to the counter to tell them what happened and they said "must be your gun". Anyone else have issues with the RWS ammo or should I be concerned?

Last edited by ejfalvo; April 11, 2013 at 07:35 PM.
ejfalvo is offline  
Old April 11, 2013, 07:51 PM   #2
highbrow
Member
 
Join Date: November 22, 2007
Location: Montana
Posts: 92
I also have an XDS. Never tried RWS ammo, hell, have never seen any here. I have not had any problems with any ammo I've tried. If I see RWS ammo, I will pass on it.
__________________
Mosin: Know the safety, Love the safety, Be the safety

There are some corners of this country which have bred the most terrible things, things that act against everything we believe in. They must be fought. FBHO- Free Edward Snowden
highbrow is offline  
Old April 11, 2013, 09:39 PM   #3
57K
Junior member
 
Join Date: March 2, 2013
Location: Heart of Texas
Posts: 788
Sounds like the RWS rounds had high seated primers. The first strike probably only seated them to the proper depth without igniting. Give them a second strike and they should go off. That will prove the primers weren't properly seated at the factory. If that's not the case, your problem lies elsewhere. Not likely since your other brands of ammo are firing without a hitch.
57K is offline  
Old April 11, 2013, 09:44 PM   #4
9mmsnoopy
Senior Member
 
Join Date: December 14, 2004
Location: Thrillsville ,Tx
Posts: 903
My xds did the same thing, only with PMC ammo, i had one round in every box of 50 that wouldnt fire and the primers had nice dings in them. Its shot everything else just fine but i havent tried any RWS.
__________________
beretta cx4 storm .40 caliber
sig P290
Kahr PM9 Glock 26
Bushmaster AR15
9mmsnoopy is offline  
Old April 11, 2013, 09:44 PM   #5
arizona98tj
Senior Member
 
Join Date: December 10, 2007
Location: Arizona
Posts: 973
ejfalvo.....just curious....are you running the PRP spring kit by any chance?
__________________
stu-offroad.com
Largest Jeep TJ project site on the web!
(now with guns)
arizona98tj is offline  
Old April 12, 2013, 01:14 AM   #6
labhound
Senior Member
 
Join Date: August 24, 2010
Posts: 306
I bought a box of .45acp RWS and had light strikes with it in both my Ruger SR45 and my Springfield XD45. Haven't had a problem with either gun with several other brands of ammo. HARD PRIMERS!!! I still have half a box of the stuff and won't be buying any more of it.
labhound is offline  
Old April 12, 2013, 02:49 AM   #7
ejfalvo
Senior Member
 
Join Date: February 8, 2009
Posts: 239
Arizona, just running stock springs.
ejfalvo is offline  
Old April 12, 2013, 06:37 AM   #8
arizona98tj
Senior Member
 
Join Date: December 10, 2007
Location: Arizona
Posts: 973
Re: XDs ammo issue.

I'm sure you have, but is it safe to say that the striker channel in the slide is clean? No lube is needed there.
arizona98tj is offline  
Old April 12, 2013, 07:38 AM   #9
Kreyzhorse
Senior Member
 
Join Date: April 12, 2006
Location: NKY
Posts: 11,482
If all other ammo shoots fine, then this is simply the RWS ammo. As per one of the posts above, I would be tempted to run them through one more time.
__________________
"He who laughs last, laughs dead." Homer Simpson

Last edited by Kreyzhorse; April 12, 2013 at 07:47 AM.
Kreyzhorse is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07040 seconds with 9 queries