The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old April 3, 2013, 10:45 PM   #1
sas955
Junior Member
 
Join Date: April 3, 2013
Posts: 2
Problem with LMT AR

I've been lurking on this site for a while since I'm new to the AR world. Hopefully you guys can help me resolve my problem. I have a LMT .556/.223 Ar with a Young National Match Bolt Carrrier Group.
The problem I'm having is when I shoot, the gun discharges the spent cartridge and injects a fresh cartridge in the chamber with no problem. When I go to fire another shoot nothing happens. The trigger is not set and I'll eject the chambered cartridge and you can see where to firing pin has made contact but not enough to fire the bullet. I've even had instances where the gun would fire 2 rapid shots with one pull of the trigger. Also, after shooting these rapid 2 rounds and the gun chambers the next round it also shows where the firing pin has made contact.After this happens you can't flip the safety lever to safe. It's locked in the fire position. I went to the range the other day and ended up throwing away a dozen or more bullets before giving up until I can fix the problem. I would very much appreciate any advise or suggestions to help remedy my problem. Thanks.
sas955 is offline  
Old April 3, 2013, 10:58 PM   #2
DnPRK
Senior Member
 
Join Date: August 24, 2001
Location: LC, Ca
Posts: 1,778
The firing pin is free floating, so it will leave a tiny impression on the primer when the cartridge is chambered. This is normal.

Your problem is a bad disconnector. It isn't catching the hammer when the bolt carrier cycles. This causes the hammer to follow the bolt carrier when it goes into battery. Do you know which type/brand of trigger you have installed? A picture would help identify it.
DnPRK is offline  
Old April 4, 2013, 10:53 AM   #3
sas955
Junior Member
 
Join Date: April 3, 2013
Posts: 2
I will post a picture later on today. Where would be the best place to order this part and is it simple to replace. Thanks
sas955 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06112 seconds with 9 queries