The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old January 28, 2013, 08:42 PM   #1
arch308
Senior Member
 
Join Date: November 6, 2011
Location: DFW, Texas
Posts: 876
Help with my 1911

I was replacing the springs in my Colt's Combat Commander (1st time ). After I got it back together the trigger won't release the hammer.(it won't shoot) I'm trying to take it back apart to find my mistake but now the safety won't come out. It was difficult the first time but now won't budge. Have even tried a brass punch on the pin head and using a small screwdriver to pry it out. Any suggestions?

Never mind,I got it out. But still don't know why it wouldn't function.

Last edited by arch308; January 28, 2013 at 08:54 PM.
arch308 is offline  
Old January 28, 2013, 09:07 PM   #2
Creeper
Senior Member
 
Join Date: September 9, 2008
Location: Woooooshington
Posts: 1,797
Could be any number of things. Here are a couple of guides that will aid you in detail D&R. The thumb safety should pop right out if you have it in the right position... if you need to use force, you're doing it wrong.

http://www.m1911.org/stripin1.htm

http://www.10-8performance.com/pages...27s-Guide.html

Pay close attention to the disconnector and sear installation as well as the sear spring.

Cheers,
C
__________________
Shoulder Drive Nicholson Club
Creeper is offline  
Old January 28, 2013, 09:42 PM   #3
arch308
Senior Member
 
Join Date: November 6, 2011
Location: DFW, Texas
Posts: 876
Got it. The leaf spring was wrong. Found video on line. Thanks much!
arch308 is offline  
Old January 28, 2013, 09:56 PM   #4
Creeper
Senior Member
 
Join Date: September 9, 2008
Location: Woooooshington
Posts: 1,797
Quote:
The leaf spring was wrong.
Happens all the time. Once you know what right is, you don't do wrong again.

Cheers,
C
__________________
Shoulder Drive Nicholson Club
Creeper is offline  
Old January 30, 2013, 04:15 PM   #5
polyphemus
Senior Member
 
Join Date: June 24, 2012
Posts: 539
"Got it. The leaf spring was wrong."
Now that you know what you did not correctly do,you could help others who may experience that issue by describing your solution.thanks
polyphemus is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06509 seconds with 9 queries