The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old January 3, 2013, 09:03 PM   #1
msnden
Member
 
Join Date: December 15, 2009
Posts: 52
.22 ejection problem

My older Winchester, model 121 single shot will not eject the CCI Velocitor ammo, it seems the bolt will not grab the casing, I have no problem with other ammo I use, so far it is just the Velocitor. Could the CCI casing be a bit smaller? or could it just be dirty? Thanks msn
msnden is offline  
Old January 3, 2013, 09:52 PM   #2
Scorch
Senior Member
 
Join Date: February 13, 2006
Location: Washington state
Posts: 11,339
A lot of the hyper-velocity ammo operates at very close to max pressure. The Velocitor ammo probably sticks to the chamber better, likely the extractor grabs it just fine but can't dislodge it, so it pulls off the rim. Stick to other ammo.
__________________
Never try to educate someone who resists knowledge at all costs.
But what do I know?
Summit Arms Services
Taylor Machine
Scorch is offline  
Old January 4, 2013, 11:19 AM   #3
msnden
Member
 
Join Date: December 15, 2009
Posts: 52
Scorch, Thanks for taking the time, Good advise, & I will follow it, Msn
msnden is offline  
Old January 4, 2013, 03:43 PM   #4
g.willikers
Senior Member
 
Join Date: September 28, 2008
Posts: 4,309
If you're curious if this is the problem, try a little anti seize on one of the suspect cases and see what happens.
If it is and you still want to use this ammo, no reason the chamber can't be cleaned up and smoothed out to prevent the problem.
Just a thought.
__________________
Lock the doors, they're coming in the windows.
g.willikers is offline  
Old January 4, 2013, 04:10 PM   #5
Ifishsum
Senior Member
 
Join Date: September 15, 2005
Location: Oregon
Posts: 689
Good chance that cleaning and polishing the chamber would help.
Ifishsum is offline  
Old January 4, 2013, 04:38 PM   #6
Erno86
Senior Member
 
Join Date: September 22, 2012
Location: Marriottsville, Maryland
Posts: 462
My recent purchase of a number of 22lr, CCI 525 rd Blazer bulk box's...are coated with heavy duty lube wax. After like shooting 30-50 rounds in my match grade chambered Kimber Classic --- I have failures to eject, with the round stuck in the chamber. I have to press down on the extractor bar, to get the spent or live round to eject. After that...I swab out the chamber with a Q-Tip soaked with degreaser --- then a dry one.
Erno86 is offline  
Old January 15, 2013, 12:08 AM   #7
norb5150
Junior Member
 
Join Date: December 11, 2012
Location: Erie, PA
Posts: 4
It is the CCI ammo

The CCI ammo is the colprit of this issue in .22lr. The ammo IMO is good to use but you must clean the breech and chamber quite a bit because the CCI ammo has a coating like wax on it that builds up very quickly and causes the case to get stuck. I was almost going to head to a Local Smith when I found out the cause. Use a pick from a AR cleaning kit and you will be able to actually peel the build up from around the chamber of the effected rifle.
norb5150 is offline  
Old January 15, 2013, 12:23 AM   #8
James K
Staff
 
Join Date: March 17, 1999
Posts: 18,637
If XYZ ammo causes problems, why use it?

Jim
__________________
Jim K
James K is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07225 seconds with 9 queries