The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old May 21, 2012, 08:16 PM   #1
TrueBrit
Member
 
Join Date: April 27, 2006
Location: canton ohio
Posts: 28
Springfield model 67 pump action

I have a Springfield model 67 pump action which fires pretty good but after firing one round the pump does not work unless I press the pump release near the trigger. It feeds the next round ok but then after firing the round this happens again and againanybody know what is causing this!!!!

Thanks
__________________
WHEN YOU CARE ENOUGH TO SEND THE VERY BEST
TrueBrit is offline  
Old June 13, 2012, 11:28 PM   #2
TrueBrit
Member
 
Join Date: April 27, 2006
Location: canton ohio
Posts: 28
Bump still need help here anyone?
__________________
WHEN YOU CARE ENOUGH TO SEND THE VERY BEST
TrueBrit is offline  
Old June 14, 2012, 07:33 AM   #3
Goatwhiskers
Senior Member
 
Join Date: April 8, 2009
Location: Batchelor, La.
Posts: 468
Of course the first thing is take the thing apart and clean it, by the way loosen the stock bolt before trying to remove the floor plate screw and pin. Then there is a crooked little spring affair that hooks onto the hammer and pushes the action bar lock out of engagement when the hammer falls. Cycle the hammer while holding the trigger assembly and you should see the problem. Goat
Goatwhiskers is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06658 seconds with 9 queries