The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old October 11, 2010, 11:24 PM   #1
RDaum
Junior Member
 
Join Date: October 11, 2010
Posts: 3
PT140 Problems

I attempted to field strip my Taurus PT140 tonight - followed the manual direction to a tee; removed slide latch, pulled trigger and it locked up totally. Won't move a millimeter forward or backward. I'm seeing a gunsmith in my future unless someone knows how to get it moving..............

I have a number of pistols and have had no issues field stripping - have field stripped the PT140 twice before with no problem.
RDaum is offline  
Old October 13, 2010, 12:22 PM   #2
zhangman
Junior Member
 
Join Date: August 29, 2010
Location: West Georgia
Posts: 13
At the moment, just a thought.... You haven't by any chance engaged the manual lock? You know with the little key?

zhangman
zhangman is offline  
Old October 15, 2010, 05:28 AM   #3
larryh1108
Senior Member
 
Join Date: July 26, 2008
Location: the foothills of CT
Posts: 592
That happens a lot with the Pro series and is an easy fix.
Here's a link:

http://www.taurusarmed.net/forums/in...?topic=10736.0
__________________
Fool me once, shame on you. Fool me twice, shame on me.
larryh1108 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06441 seconds with 9 queries