The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old February 1, 2009, 07:59 PM   #1
boatmonkey82
Junior member
 
Join Date: December 31, 2008
Location: youngsville nc
Posts: 195
help before i destroy the marlin 60 !!

ok i have a older glennfield marlin 60 - good gun - welli gave it a good cleaning and shot as few hundren rounds thru it and it started jamming up .thinking i had too much oil in it it tore it down wiped it clean and lightly oiled it .upon putting it back together it felt like a dream , nice and smooth . the first shot loads fine and fires fine ejects fine but when the bolt come back to re fire it will send the next round up at about a 45 degree angle and the bolt will freeze solid. after you beat the bolt back and get the round out the bolt will not move freely at all untill you tear it back down . i got soo ****** at it i slung it in the yard then felt bad and retreived it . throw me a line here
boatmonkey82 is offline  
Old February 1, 2009, 08:02 PM   #2
roach4047
Senior Member
 
Join Date: September 26, 2008
Posts: 189
They're cheap rifles. Save yourself the next two hours of cleaning it again and take $65.00 and go buy another used one in working condition.

Roach
roach4047 is offline  
Old February 2, 2009, 08:46 PM   #3
George R
Senior Member
 
Join Date: December 17, 2004
Location: Boca Raton, FL
Posts: 151
Marlin 60

What you have is a Marlin 99 clone. If you took the bolt apart and removed the firing pin, you might have lost the little roller in the bolt. That would make it stovepipe. If you would like detailed instructions for assembly, PM me and I'll scan them and email them to you. Your gun is IMHO still the best bargain in 22 semiautos.
George R is offline  
Old February 3, 2009, 07:57 PM   #4
Cfish
Member
 
Join Date: September 20, 2008
Location: Central FL
Posts: 25
Try this
http://www.thehighroad.org/showthread.php?t=86314
Cfish is offline  
Old February 3, 2009, 10:29 PM   #5
boatmonkey82
Junior member
 
Join Date: December 31, 2008
Location: youngsville nc
Posts: 195
no i 100% sure it is put together right , but i think the feeder is worn out. im torn here,i have a mid 90s mod 60 and a old gfield , both with family history but i get so mad at them i want to beat them on my resse hitch and throw the splinters in the burn pile !
boatmonkey82 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06757 seconds with 9 queries