The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Thread Tools Search this Thread
Old September 11, 2008, 02:01 PM   #1
Junior Member
Join Date: March 19, 2008
Posts: 13
semi auto mossberg problem

i got a semi auto mossberg 12ga and it will shoot the first shell fine but it jams when loading the second shell any one know what this could be
thanks mike
mikeg22003 is offline  
Old September 11, 2008, 11:07 PM   #2
Join Date: August 21, 2008
Posts: 91
My first thought would be: When was it last cleaned? And I dont just mean a boresnake down the pipe. Gas systems can be real finicky when dirty and it almost sounds like your shotty is short-stroking a touch. Do the shells eject strong and really fly or do they just kinda roll out of the port?
Elevator timing could be another issue.

We really need more info to get a more accurate picture of the malfunction.
How many rounds through the gun?
What condition is it in? Clean, dirty or??
What chamber and what ammo are you using?
The more info the better able to answer.
hockeysew is offline  

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 04:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2015 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent:
Contact Us
Page generated in 0.16019 seconds with 9 queries