The Firing Line Forums

Go Back   The Firing Line Forums > The North Corral > Black Powder and Cowboy Action Shooting

Reply
 
Thread Tools
Old August 18, 2008, 10:43 AM   #1
M14MSgt
Senior Member
 
Join Date: August 11, 2007
Location: Lancaster CA
Posts: 105
'47 Walker

I have a '47 Walker (Uberti) and everytime I remove the front frame to remove the cylinder for reloading, I find that no matter how hard I push the frame back on the two pins, I still end up using a rubber mallet on the muzzle to force the frame together so the wedge will fit back in. This cannot be normal procedure! I would have thought that after a lot of use, this would fit easier, but it doesn't. Anyone else have this issue? I can't see having to hammer the frame together each time you reload. Please advise...
M14MSgt is offline  
Old August 18, 2008, 11:08 AM   #2
sundance44s
Senior Member
 
Join Date: February 6, 2006
Location: Hernando , Ms.
Posts: 579
I`ve always had to do the same with mine , and it`s an ASM made Walker .
I wasn`t going to complain about mine being that way ..Just glad it was still a tight fit .
sundance44s is offline  
Old August 18, 2008, 12:06 PM   #3
Smokin_Gun
Senior Member
 
Join Date: December 4, 2005
Location: Mojave Desert, CA
Posts: 1,195
It does sound like a good thing... I bet both you guys wedges fit right too.


MSGT...I'm in Palmdale, belong to Desert Marksmen Club.

Tryin' to talk Sundance into joinin...LoL!


SG
__________________
"I Smoke Black Powder" "Favor an 1858 Remington"
SGT. Smokin' Gun, Mosby's Rangers 43rd Virginia Cavalry C.S.A.
SASS# 19634, ...
Admin:http://blackpowdersmoke.com/oldcoots/index.php
Smokin_Gun is offline  
Old August 18, 2008, 01:15 PM   #4
M14MSgt
Senior Member
 
Join Date: August 11, 2007
Location: Lancaster CA
Posts: 105
Smokin Gun - I shoot there also. In fact, was there Saturday. Most of the time, I have the place to myself.
M14MSgt is offline  
Old August 18, 2008, 02:03 PM   #5
mykeal
Senior Member
 
Join Date: October 8, 2006
Location: Northern Michigan
Posts: 2,757
I'd have to say it's more normal than not - my Uberti is like that, my ASM is not.
mykeal is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06157 seconds with 9 queries