The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old August 4, 2008, 06:04 AM   #1
sschopfer
Junior Member
 
Join Date: August 3, 2008
Posts: 2
Mini 14 Problem

I own an older Mini 14, bought in the 70's, which is stainless steel. It was never a great performer even with a 3-9 scope. Recently, I have spent some time and effort to add the Tapco stock conversion, an OETech 512 holographic sight, and the Streamligt TRL2 light and laser combination. Looks great with a 40 round mag, but I am having some problems with the cycling of the action. More often than I feel comfortable with, the bolt does not close all of the way. It gets hung up or binds about 1/2 inch from completly closing. Then when you pull the trigger, it does not fire since it is not making contact with the round in the chamber. If I cycle the action, it picks up the next round in the mag and trys to chamber it. But it cant't since the live round in the chamber has not ejected yet.

I've tried various ammo with the same results. I spent a ridiculous amount of money on two 20 rounds mags that were factory Ruger...same results.

Now I'm thinking I will put the old wooden stock back on and see if the problem is the Tapco stock binding some place.

I can hear metal on metal contact when I cycle the action slowly. When I cycle it hard manually, it slams past the area where it binds up.
sschopfer is offline  
Old August 4, 2008, 12:31 PM   #2
doug66
Senior Member
 
Join Date: June 1, 2008
Location: Kansas
Posts: 116
If it won't run in its original condition, then send it in to Ruger. I bought my Mini 20 some years ago used. Here awhile back it started to act up. Wouldn't cycle. I field stripped it, bought some factory ammo, tried OEM mag no go.
Sent it to Connecticut for about a month, she's good as new. They replaced bolt, gas block and piston. All it cost me was shipping. Ruger is a class act.
doug66 is offline  
Old August 7, 2008, 08:49 AM   #3
detrod
Member
 
Join Date: August 27, 2005
Location: Moses Lake,WA
Posts: 39
Mini-14

YEP ! Doug66 is right.... send it back.
detrod is offline  
Old August 7, 2008, 09:47 AM   #4
sschopfer
Junior Member
 
Join Date: August 3, 2008
Posts: 2
Thanks Guys,

As soon as I have a free minute or two, I will put the old stock on and fire a few clips.

If I still have problems, I will contact Ruger.
sschopfer is offline  
Old August 9, 2008, 08:44 AM   #5
Tom2
Senior Member
 
Join Date: June 23, 2004
Location: Ohio
Posts: 5,648
Lube problem? Weak return spring? High round count? Possibly something is just worn out from use. Maybe it is time to trade in for one of the newest ones that are supposedly more accurate due to Ruger finally setting up and taking notice of aftermarket accurizing work on them. And you could presumably keep your accessories, like mags? I am assuming they all take the same mags.
__________________
Your gun is like your nose, it is just wrong for someone else to pick it for you!
Tom2 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2013 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07160 seconds with 9 queries