The Firing Line Forums

Go Back   The Firing Line Forums > The Skunkworks > The Smithy

Reply
 
Thread Tools
Old January 26, 2000, 07:30 PM   #1
Corey
Member
 
Join Date: February 14, 1999
Posts: 58
I am having trouble with rounds jamming in my Mark 1. It will fire the first round and then it catches the second round about dead center and puts a good gouge in it. I am not sure whether it is a magazine problem or something else. If any of you have an idea what is wrong I would appreciate the input.

Corey
Corey is offline  
Old January 27, 2000, 12:57 AM   #2
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Corey, try a different magazine and see if the same thing happens. You might also give the feed ramp and chamber entrace a good look for burrs but I beleive its the mag. George
George Stringer is offline  
Old January 27, 2000, 01:00 AM   #3
George Stringer
Staff Alumnus
 
Join Date: October 12, 1998
Location: Earlington KY
Posts: 2,299
Corey, try a different magazine and see if the same thing happens. You might also give the feed ramp and chamber entrace a good look for burrs but I beleive its the mag. It's probably actually hitting on the first but the slide is farther back and you're getting more umph from the recoil spring. George
George Stringer is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.05781 seconds with 9 queries