The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > NFA Guns and Gear

Reply
 
Thread Tools
Old September 4, 2000, 02:47 PM   #1
Normalizer
Senior Member
 
Join Date: June 4, 2000
Location: TN
Posts: 110
Took my new (to me) uzi out to the range yesterday, gotta say I loved it! As it warmed up it got faster and faster.... lots of fun!

Had a problem though that I've not yet fixed, though I think I know the solution.... the knob on bolt that you charge it with would come loose and cause the gun to fail, requiring that I tighten it back down where it would just do it again about 5 rounds or so later. I'm thinking a dab of locktite will do the trick but before I put some on the threads wanted to post here and see if this is a common problem and if there is a better solution.

Gotta get a speed loader too... fer sure...
Normalizer is offline  
Old September 7, 2000, 12:22 PM   #2
Byron Quick
Staff In Memoriam
 
Join Date: November 13, 1998
Location: Waynesboro, Georgia, USA
Posts: 2,361
I've never had a problem with my Uzi.

------------------
Byron Quick

Byron Quick is offline  
Old September 8, 2000, 03:25 PM   #3
Coinneach
Staff Alumnus
 
Join Date: February 23, 1999
Location: Denver, CO
Posts: 4,273
Norm, loctite should fix the problem, but I gotta admit I've never seen the charging knob work loose. As it doesn't move with the rest of the bolt, the only motion it experiences under use is vibration. Weird.
Coinneach is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.06862 seconds with 9 queries