The Firing Line Forums

Go Back   The Firing Line Forums > The Hide > The Dave McCracken Memorial Shotgun Forum

Reply
 
Thread Tools
Old November 25, 2002, 11:04 PM   #1
91B40
Member
 
Join Date: November 8, 2002
Location: Crescent City, CA
Posts: 17
Estate SWAT Buckshot-Sticky Extraction

Anyone had a problem with difficult extraction with the Estate SWAT Buckshot load? I went shooting today and had several Estate rounds that were quite hard to extract. No such problem occurred with Winchester AA, Remington 2 3/4" Magnum 1 buck, surplus GI XM162 (Winchester Vietnam-issue), or Federal H13200. Gun is my old reliable 870 Marine Magnum. It was clean when I started the range session. Nothing appears to be out of order and I finished up with 50 Winchester Light Targets without the slightest hint of trouble, as usual with this gun. By the way, the Estate load patterned as well as the Federal and shot to the same point of aim.
91B40 is offline  
Old November 26, 2002, 01:38 AM   #2
lockandrock
Registration in progress
 
Join Date: December 26, 2001
Location: sunshine Fl
Posts: 122
No problems with extraction for me.

btw: The swat load shot about 6 to 7" patterns out of a 870 IC @ 25yrds. Also recoil is not bad
lockandrock is offline  
Old November 26, 2002, 05:49 AM   #3
Dave McC
Staff In Memoriam
 
Join Date: October 13, 1999
Location: Columbia, Md, USA
Posts: 8,812
I've only shot about 40 rounds of this so far, no glitches.

Even with good shotguns and ammo, there's occasional incompatabilities. If a brand and kind of ammo doesn't work 100% in YOUR shotgun, use something that does.

This further reinforces the old rule about running some duty stuff through your weapon periodically.
Dave McC is offline  
Old November 26, 2002, 08:55 AM   #4
HSMITH
Senior Member
 
Join Date: June 21, 2002
Posts: 2,019
I have shot tens of thousands of rounds of estate buckshot and would occasionally see a round that was hard to extract but I never did isolate it to a particular brand.

Polish the chamber, check the extractor tip, make sure the magazine cap is only on snug and not gorilla tight. Also check your action bars, if you were really working hard I have seen guys twisting them to the point where they bind and cause what you describe.

If you do get one that was hard to extract take it home and give a good examination, look for scratches etc that might have caused it.
HSMITH is offline  
Old November 26, 2002, 10:11 PM   #5
91B40
Member
 
Join Date: November 8, 2002
Location: Crescent City, CA
Posts: 17
Thanks for the replies. I now have an excuse to go back out and shoot another 100 or so of this load to see if the problem happens again.
91B40 is offline  
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site and contents, including all posts, Copyright © 1998-2014 S.W.A.T. Magazine
Copyright Complaints: Please direct DMCA Takedown Notices to the registered agent: thefiringline.com
Contact Us
Page generated in 0.07097 seconds with 9 queries