View Single Post
Old October 26, 2012, 07:36 PM   #1
tatorsattic
Junior Member
 
Join Date: October 26, 2012
Posts: 1
Browning A5 cycling troubles...

New to this site and in need of some advice.
I have two Browning A5 shotguns - both are giving me problems. I'll start with just one and see where that gets me.
The first gun/issue - A Browning A5 Sweet 16 - serial # 76S 16006; in great shape and have had for 20+ years - but just began shooting it for the first time this month. I have just started with Sporting Clays in the last few weeks to get ready for a pheasant hunt next month. The gun has on each occasion, started out just fine - I start with bolt locked back, insert a round using the speed loading and it auto cycles into battery, i then load a second round and everything works just fine. then, after going through 20-30 rounds, the bolt will stop locking back and/or upon inserting a round into the magazing, cycling the bolt will not get the round from the magazine to cycle up into battery. Once this begins happening, there are fewer and fewer occasions where it works correctly - and more and more manipulation of the bolt and the carrier assembly is needed to get it to either work or to get it to unload, because it just won't cycle on its own or even manually. Another symptom is the failure to eject the spent round(s) once the problems start. I'm using Remington Game loads - 2 3/4" with # 7.5 shot. The gun was thoroughly cleaned and the mag tube has been well lubed(but not overly) and I have made sure the friction rings are correctly placed for light loads.
I hope I have not gone on too long, but given enough info for you more experienced shotgunners to give me some help. Any feedback gratefully accepted.
tatorsattic is offline  
 
Page generated in 0.04461 seconds with 7 queries